What’s Vulnerable › Vulnerabilities
CVE-2022-24095: Adobe After Effects Stack-based Buffer Overflow Arbitrary code execution
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-11 · updated 2026-06-17
- Weakness: CWE-121
Description
Adobe After Effects versions 22.2 (and earlier) and 18.4.4 (and earlier) are affected by a Stack-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe After Effects: from 18.0 before 18.4.5; from 22.0 before 22.2.1 — fixed in 18.4.5, 22.2.1
How to fix
Upgrade to a fixed version: Adobe After Effects 18.4.5, 22.2.1. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/after_effects/apsb22-17.html
- https://helpx.adobe.com/security/products/after_effects/apsb22-17.html
Get alerted when CVE-2022-24095 or the next vulnerability affects your stack