What’s Vulnerable › Vulnerabilities
CVE-2022-24107
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-30 · updated 2026-06-17
- Weakness: CWE-190
Description
Xpdf prior to 4.04 lacked an integer overflow check in JPXStream.cc.
Affected products
- Glyphandcog Xpdfreader: before 4.04 — fixed in 4.04
How to fix
Upgrade to a fixed version: Glyphandcog Xpdfreader 4.04. Check the vendor advisory for mitigations.
References
- http://www.xpdfreader.com/security-fixes.html
- https://dl.xpdfreader.com/xpdf-4.04.tar.gz
- http://www.xpdfreader.com/security-fixes.html
- https://dl.xpdfreader.com/xpdf-4.04.tar.gz
Get alerted when CVE-2022-24107 or the next vulnerability affects your stack