What’s Vulnerable › Vulnerabilities
CVE-2022-24112: Apache APISIX Authentication Bypass Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-08-25
- EPSS: 96.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-11 · updated 2026-06-17
- Weakness: CWE-290
Description
An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.
Affected products
- Apache Software Foundation Apache APISIX: before 2.10.4; from 2.11.0 before 2.12.1 — fixed in 2.10.4, 2.12.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 2.10.4, 2.12.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/166228/Apache-APISIX-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/166328/Apache-APISIX-2.12.1-Remote-Code-Execution.html
- http://www.openwall.com/lists/oss-security/2022/02/11/3
- https://lists.apache.org/thread/lcdqywz8zy94mdysk7p3gfdgn51jmt94
- http://packetstormsecurity.com/files/166228/Apache-APISIX-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/166328/Apache-APISIX-2.12.1-Remote-Code-Execution.html
- http://www.openwall.com/lists/oss-security/2022/02/11/3
- https://lists.apache.org/thread/lcdqywz8zy94mdysk7p3gfdgn51jmt94
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-24112
Get alerted when CVE-2022-24112 or the next vulnerability affects your stack