What’s Vulnerable › Vulnerabilities
CVE-2022-24129
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-04 · updated 2026-06-17
- Weakness: CWE-918
Description
The OIDC OP plugin before 3.0.4 for Shibboleth Identity Provider allows server-side request forgery (SSRF) due to insufficient restriction of the request_uri parameter. This allows attackers to interact with arbitrary third-party HTTP services.
Affected products
- Shibboleth Oidc Op: before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: Shibboleth Oidc Op 3.0.4. Check the vendor advisory for mitigations.
References
- http://shibboleth.net/community/advisories/
- http://shibboleth.net/community/advisories/secadv_20220131.txt
- https://github.com/sbaresearch/advisories/tree/public/2022/SBA-ADV-20220127-01_Shibboleth_IdP_OIDC_OP_Plugin_SSRF
- http://shibboleth.net/community/advisories/
- http://shibboleth.net/community/advisories/secadv_20220131.txt
- https://github.com/sbaresearch/advisories/tree/public/2022/SBA-ADV-20220127-01_Shibboleth_IdP_OIDC_OP_Plugin_SSRF
Get alerted when CVE-2022-24129 or the next vulnerability affects your stack