What’s Vulnerable › Vulnerabilities

CVE-2022-2417

Description

Insufficient validation in GitLab CE/EE affecting all versions from 12.10 prior to 15.0.5, 15.1 prior to 15.1.4, and 15.2 prior to 15.2.1 allows an authenticated and authorised user to import a project that includes branch names which are 40 hexadecimal characters, which could be abused in supply chain attacks where a victim pinned to a specific Git commit of the project.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.0.5, 15.1.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-2417 or the next vulnerability affects your stack