What’s Vulnerable › Vulnerabilities
CVE-2022-2421: Socket.io - Improper type validation in attachment parsing
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-26 · updated 2026-06-17
- Weakness: CWE-89
Description
Due to improper type validation in attachment parsing the Socket.io js library, it is possible to overwrite the _placeholder object which allows an attacker to place references to functions at arbitrary places in the resulting query object.
Affected products
- Socket.io-Parser: before 3.3.3; from 3.4.0 before 3.4.2; from 4.0.0 before 4.0.5; from 4.1.0 before 4.2.1 — fixed in 3.3.3, 3.4.2, 4.0.5, 4.2.1
How to fix
Upgrade to a fixed version: Socket.io-Parser 3.3.3, 3.4.2, 4.0.5, 4.2.1. Check the vendor advisory for mitigations.
References
- https://csirt.divd.nl/CVE-2022-2421
- https://csirt.divd.nl/DIVD-2022-00045
- https://csirt.divd.nl/CVE-2022-2421
- https://csirt.divd.nl/DIVD-2022-00045
Get alerted when CVE-2022-2421 or the next vulnerability affects your stack