What’s Vulnerable › Vulnerabilities
CVE-2022-2422: Feathers - SQL injection via attribute aliases
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-26 · updated 2026-06-17
- Weakness: CWE-89
Description
Due to improper input validation in the Feathers js library, it is possible to perform a SQL injection attack on the back-end database, in case the feathers-sequelize package is used.
Affected products
- Feather js Feathers-Sequalize: from 6.0.0 before 6.3.4 — fixed in 6.3.4
How to fix
Upgrade to a fixed version: Feather js Feathers-Sequalize 6.3.4. Check the vendor advisory for mitigations.
References
- https://csirt.divd.nl/CVE-2022-2422
- https://csirt.divd.nl/DIVD-2022-00020
- https://csirt.divd.nl/CVE-2022-2422
- https://csirt.divd.nl/DIVD-2022-00020
Get alerted when CVE-2022-2422 or the next vulnerability affects your stack