What’s Vulnerable › Vulnerabilities
CVE-2022-24280: Apache Pulsar Proxy target broker address isn't validated
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-23 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Proxy component of Apache Pulsar allows an attacker to make TCP/IP connection attempts that originate from the Pulsar Proxy's IP address. When the Apache Pulsar Proxy component is used, it is possible to attempt to open TCP/IP connections to any IP address and port that the Pulsar Proxy can connect to. An attacker could use this as a way for DoS attacks that originate from the Pulsar Proxy's IP address. It hasn’t been detected that the Pulsar Proxy authentication can be bypassed. The attacker will have to have a valid token to a properly secured Pulsar Proxy. This issue affects Apache Pulsar Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.2; 2.9.0 to 2.9.1; 2.6.4 and earlier.
Affected products
- Apache Software Foundation Apache Pulsar: through 2.6.4; from 2.7.0 before 2.7.5; from 2.8.0 before 2.8.3; from 2.9.0 before 2.9.2 — fixed in 2.7.5, 2.8.3, 2.9.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pulsar 2.7.5, 2.8.3, 2.9.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/ghs9jtjfbpy4c6xcftyvkl6swznlom1v
- https://lists.apache.org/thread/ghs9jtjfbpy4c6xcftyvkl6swznlom1v
Get alerted when CVE-2022-24280 or the next vulnerability affects your stack