What’s Vulnerable › Vulnerabilities
CVE-2022-24288: Apache Airflow: RCE in example DAGs
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 77.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-25 · updated 2026-06-17
- Weakness: CWE-78
Description
In Apache Airflow, prior to version 2.2.4, some example DAGs did not properly sanitize user-provided params, making them susceptible to OS Command Injection from the web UI.
Affected products
- Apache Airflow: before 2.2.4 — fixed in 2.2.4
How to fix
Upgrade to a fixed version: Apache Airflow 2.2.4. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/dbw5ozcmr0h0lhs0yjph7xdc64oht23t
- https://lists.apache.org/thread/dbw5ozcmr0h0lhs0yjph7xdc64oht23t
Get alerted when CVE-2022-24288 or the next vulnerability affects your stack