What’s Vulnerable › Vulnerabilities
CVE-2022-24290
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-121
Description
A vulnerability has been identified in Teamcenter V12.4 (All versions < V12.4.0.13), Teamcenter V13.0 (All versions < V13.0.0.9), Teamcenter V13.1 (All versions), Teamcenter V13.2 (All versions < V13.2.0.8), Teamcenter V13.3 (All versions < V13.3.0.3), Teamcenter V14.0 (All versions < V14.0.0.2). The tcserver.exe binary in affected applications is vulnerable to a stack overflow condition during the parsing of user input that may lead the binary to crash.
Affected products
- Siemens Teamcenter: from 12.4 before 12.4.0.13; from 13.0 before 13.0.0.9; from 13.1 before 13.1.0.9; from 13.2 before 13.2.0.8; from 13.3 before 13.3.0.3; 14.0 — fixed in 12.4.0.13, 13.0.0.9, 13.1.0.9, 13.2.0.8, 13.3.0.3
How to fix
Upgrade to a fixed version: Siemens Teamcenter 12.4.0.13, 13.0.0.9, 13.1.0.9, 13.2.0.8. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-789162.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-789162.pdf
Get alerted when CVE-2022-24290 or the next vulnerability affects your stack