What’s Vulnerable › Vulnerabilities
CVE-2022-24299
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-31 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper input validation vulnerability in pfSense CE and pfSense Plus (pfSense CE software versions prior to 2.6.0 and pfSense Plus software versions prior to 22.01) allows a remote attacker with the privilege to change OpenVPN client or server settings to execute an arbitrary command.
Affected products
- Netgate pfSense: before 2.6.0 — fixed in 2.6.0
- Netgate Pfsense Plus: before 22.01 — fixed in 22.01
How to fix
Upgrade to a fixed version: Netgate pfSense 2.6.0; Netgate Pfsense Plus 22.01. Check the vendor advisory for mitigations.
References
- https://docs.netgate.com/downloads/pfSense-SA-22_03.webgui.asc
- https://jvn.jp/en/jp/JVN87751554/index.html
- https://docs.netgate.com/downloads/pfSense-SA-22_03.webgui.asc
- https://jvn.jp/en/jp/JVN87751554/index.html
Get alerted when CVE-2022-24299 or the next vulnerability affects your stack