What’s Vulnerable › Vulnerabilities
CVE-2022-24302
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-17 · updated 2026-06-17
- Weakness: CWE-362
Description
In Paramiko before 2.10.1, a race condition (between creation and chmod) in the write_private_key_file function could allow unauthorized information disclosure.
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 34, 35, 36
- Paramiko: before 2.10.1 — fixed in 2.10.1
- Pypi Paramiko: before 2.9.3; from 2.10.0 before 2.10.1; 0.1-bulbasaur, 0.1-charmander, 0.9-doduo, 0.9-eevee, 0.9-fearow, 0.9-gyarados (+121) — fixed in 2.9.3, 2.10.1
How to fix
Upgrade to a fixed version: Paramiko 2.10.1; Pypi Paramiko 2.9.3, 2.10.1. Check the vendor advisory for mitigations.
References
- https://github.com/paramiko/paramiko/blob/363a28d94cada17f012c1604a3c99c71a2bda003/paramiko/pkey.py#L546
- https://lists.debian.org/debian-lts-announce/2022/03/msg00032.html
- https://lists.debian.org/debian-lts-announce/2022/09/msg00013.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LUEUEGILZ7MQXRSUF5VMMO4SWJQVPTQL/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TPMKRUS4HO3P7NR7P4Y6CLHB4MBEE3AI/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U63MJ2VOLLQ35R7CYNREUHSXYLWNPVSB/
- https://www.paramiko.org/changelog.html
- https://github.com/paramiko/paramiko/blob/363a28d94cada17f012c1604a3c99c71a2bda003/paramiko/pkey.py#L546
- https://lists.debian.org/debian-lts-announce/2022/03/msg00032.html
- https://lists.debian.org/debian-lts-announce/2022/09/msg00013.html
- https://lists.debian.org/debian-lts-announce/2025/12/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LUEUEGILZ7MQXRSUF5VMMO4SWJQVPTQL/
Get alerted when CVE-2022-24302 or the next vulnerability affects your stack