What’s Vulnerable › Vulnerabilities
CVE-2022-24307
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-03 · updated 2026-06-17
- Weakness: CWE-863
Description
Mastodon before 3.3.2 and 3.4.x before 3.4.6 has incorrect access control because it does not compact incoming signed JSON-LD activities. (JSON-LD signing has been supported since version 1.6.0.)
Affected products
- mastodon: before 3.3.2; from 3.4.0 before 3.4.6 — fixed in 3.3.2, 3.4.6
How to fix
Upgrade to a fixed version: mastodon 3.3.2, 3.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/mastodon/mastodon/releases/tag/v3.3.2
- https://github.com/mastodon/mastodon/releases/tag/v3.4.6
- https://github.com/mastodon/mastodon/releases/tag/v3.3.2
- https://github.com/mastodon/mastodon/releases/tag/v3.4.6
Get alerted when CVE-2022-24307 or the next vulnerability affects your stack