What’s Vulnerable › Vulnerabilities
CVE-2022-24309
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-08 · updated 2026-06-17
- Weakness: CWE-284
Description
A vulnerability has been identified in Mendix Runtime V7 (All versions < V7.23.29), Mendix Runtime V8 (All versions < V8.18.16), Mendix Runtime V9 (All versions < V9.13 only with Runtime Custom Setting *DataStorage.UseNewQueryHandler* set to False). If an entity has an association readable by the user, then in some cases, Mendix Runtime may not apply checks for XPath constraints that parse said associations, within apps running on affected versions. A malicious user could use this to dump and manipulate sensitive data.
Affected products
- Siemens Mendix Applications using Mendix 7: before 7.23.29; from 8.0.0 before 8.18.16; from 9.0.0 before 9.13 — fixed in 7.23.29, 8.18.16, 9.13
How to fix
Upgrade to a fixed version: Siemens Mendix Applications using Mendix 7 7.23.29, 8.18.16, 9.13. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/html/ssa-148641.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-148641.pdf
- https://cert-portal.siemens.com/productcert/html/ssa-148641.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-148641.pdf
Get alerted when CVE-2022-24309 or the next vulnerability affects your stack