What’s Vulnerable › Vulnerabilities
CVE-2022-24329
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-25 · updated 2026-06-17
- Weakness: CWE-829
Description
In JetBrains Kotlin before 1.6.0, it was not possible to lock dependencies for Multiplatform Gradle Projects.
Affected products
- JetBrains Kotlin: before 1.6.0 — fixed in 1.6.0
- Oracle Communications Cloud Native Core Binding Support Function: 22.1.3
- Oracle Corporation Communications Pricing Design Center: 12.0.0.4, 12.0.0.5
How to fix
Upgrade to a fixed version: JetBrains Kotlin 1.6.0. Check the vendor advisory for mitigations.
References
- https://blog.jetbrains.com
- https://blog.jetbrains.com/blog/2022/02/08/jetbrains-security-bulletin-q4-2021/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://blog.jetbrains.com
- https://blog.jetbrains.com/blog/2022/02/08/jetbrains-security-bulletin-q4-2021/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujul2022.html
Get alerted when CVE-2022-24329 or the next vulnerability affects your stack