What’s Vulnerable › Vulnerabilities
CVE-2022-2433: WordPress Infinite Scroll – Ajax Load More <= 5.5.3 - Cross-Site Request Forgery to PHAR Deserialization
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-06 · updated 2026-06-17
- Weakness: CWE-502
Description
The WordPress Infinite Scroll – Ajax Load More plugin for WordPress is vulnerable to deserialization of untrusted input via the 'alm_repeaters_export' parameter in versions up to, and including 5.5.3. This makes it possible for unauthenticated users to call files using a PHAR wrapper, granted they can trick a site administrator into performing an action such as clicking on a link, that will deserialize and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.
Affected products
- dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load: before 5.5.4 — fixed in 5.5.4
How to fix
Upgrade to a fixed version: dcooney Ajax Load More – Infinite Scroll, Load More, & Lazy Load 5.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/dcooney/ajax-load-more/commit/b577b3257544bc74a5d2ad14f0a0f7df3eb843de
- https://plugins.trac.wordpress.org/changeset/2772627/ajax-load-more/trunk/admin/admin.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/040ae20d-93e3-4c65-ba74-4ff0b5c1afc7?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2433
- https://plugins.trac.wordpress.org/changeset/2772627/ajax-load-more/trunk/admin/admin.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/040ae20d-93e3-4c65-ba74-4ff0b5c1afc7?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2433
Get alerted when CVE-2022-2433 or the next vulnerability affects your stack