What’s Vulnerable › Vulnerabilities
CVE-2022-24370
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-18 · updated 2026-06-17
- Weakness: CWE-125
Description
This vulnerability allows remote attackers to disclose sensitive information on affected installations of Foxit PDF Reader Foxit reader 11.0.1.0719 macOS. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handling of XFA forms. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated object. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of the current process. Was ZDI-CAN-14819.
Affected products
- Foxit PDF Reader: before 11.1.0.0925 — fixed in 11.1.0.0925
- Foxit Pdf Reader: before 11.1.0.0925 — fixed in 11.1.0.0925
How to fix
Upgrade to a fixed version: Foxit PDF Reader 11.1.0.0925; Foxit Pdf Reader 11.1.0.0925. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-22-266/
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-22-266/
Get alerted when CVE-2022-24370 or the next vulnerability affects your stack