What’s Vulnerable › Vulnerabilities
CVE-2022-2438: Broken Link Checker <= 1.11.16 - Authenticated (Admin+) PHAR Deserialization
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-06 · updated 2026-06-17
- Weakness: CWE-502
Description
The Broken Link Checker plugin for WordPress is vulnerable to deserialization of untrusted input via the '$log_file' value in versions up to, and including 1.11.16. This makes it possible for authenticated attackers with administrative privileges and above to call files using a PHAR wrapper that will deserialize the data and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.
Affected products
- wpmudev Broken Link Checker: before 1.11.17 — fixed in 1.11.17
How to fix
Upgrade to a fixed version: wpmudev Broken Link Checker 1.11.17. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2757773/broken-link-checker/trunk/core/core.php?old=2605914&old_path=broken-link-checker%2Ftrunk%2Fcore%2Fcore.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/62fd472e-208b-48db-8f98-3d935c7a678c?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2438
- https://plugins.trac.wordpress.org/changeset/2757773/broken-link-checker/trunk/core/core.php?old=2605914&old_path=broken-link-checker%2Ftrunk%2Fcore%2Fcore.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/62fd472e-208b-48db-8f98-3d935c7a678c?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2438
Get alerted when CVE-2022-2438 or the next vulnerability affects your stack