What’s Vulnerable › Vulnerabilities
CVE-2022-24390: Authenticated Command Injection Vulnerability in Fidelis Network and Deception
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-17 · updated 2026-06-17
- Weakness: CWE-78
Description
Vulnerability in rconfig “remote_text_file” enables an attacker with user level access to the CLI to inject user level commands into Fidelis Network and Deception CommandPost, Collector, Sensor, and Sandbox components as well as neighboring Fidelis components. The vulnerability is present in Fidelis Network and Deception versions prior to 9.4.5. Patches and updates are available to address this vulnerability.
Affected products
- Fidelissecurity Deception: before 9.4.5 — fixed in 9.4.5
- Fidelissecurity Network: before 9.4.5 — fixed in 9.4.5
How to fix
Upgrade to a fixed version: Fidelissecurity Deception 9.4.5; Fidelissecurity Network 9.4.5. Check the vendor advisory for mitigations.
References
- https://fidelissecurity.zendesk.com/hc/en-us/articles/6211730139411
- https://fidelissecurity.zendesk.com/hc/en-us/articles/6211730139411
Get alerted when CVE-2022-24390 or the next vulnerability affects your stack