What’s Vulnerable › Vulnerabilities
CVE-2022-2440: Theme Editor <= 2.8 - Authenticated (Admin+) PHAR Deserialization
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-502
Description
The Theme Editor plugin for WordPress is vulnerable to deserialization of untrusted input via the 'images_array' parameter in versions up to, and including 2.8. This makes it possible for authenticated attackers with administrative privileges to call files using a PHAR wrapper that will deserialize and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.
Affected products
- mndpsingh287 Theme Editor: before 2.9 — fixed in 2.9
How to fix
Upgrade to a fixed version: mndpsingh287 Theme Editor 2.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/theme-editor/trunk/ms_child_theme_editor.php#L495
- https://plugins.trac.wordpress.org/changeset/3142694/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/88fe46bf-8e85-4550-92ad-bdd426e5a745?source=cve
Get alerted when CVE-2022-2440 or the next vulnerability affects your stack