What’s Vulnerable › Vulnerabilities
CVE-2022-24417
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-26 · updated 2026-06-17
- Weakness: CWE-20
Description
Dell BIOS contains an improper input validation vulnerability. A local authenticated malicious user may potentially exploit this vulnerability by using an SMI to gain arbitrary code execution during SMM.
Affected products
- Dell G5 5505 Firmware: before 1.10.0 — fixed in 1.10.0
- Dell Inspiron 22-3275 Firmware: before 1.8.0 — fixed in 1.8.0
- Dell Inspiron 24-3475 Firmware: before 1.8.0 — fixed in 1.8.0
- Dell Inspiron 27 7775 Firmware: before 2.15.0 — fixed in 2.15.0
- Dell Inspiron 3180 Firmware: before 1.4.4 — fixed in 1.4.4
- Dell Inspiron 3185 Firmware: before 1.4.4 — fixed in 1.4.4
- Dell Inspiron 3195 Firmware: before 1.4.1 — fixed in 1.4.1
- Dell Inspiron 3505 Firmware: before 1.5.0 — fixed in 1.5.0
- Dell Inspiron 3515 Firmware: before 1.4.0 — fixed in 1.4.0
- Dell Inspiron 3585 Firmware: before 1.6.0 — fixed in 1.6.0
- Dell Inspiron 3595 Firmware: before 1.2.1 — fixed in 1.2.1
- Dell Inspiron 3785 Firmware: before 1.6.0 — fixed in 1.6.0
- Dell Inspiron 5405 Firmware: before 1.6.0 — fixed in 1.6.0
- Dell Inspiron 5415 Firmware: before 1.7.1 — fixed in 1.7.1
- Dell Inspiron 5485 Firmware: before 2.7.0 — fixed in 2.7.0
- Dell Inspiron 5505 Firmware: before 1.6.0 — fixed in 1.6.0
- Dell Inspiron 5515 Firmware: before 1.7.1 — fixed in 1.7.1
- Dell Inspiron 5575 Firmware: before 1.5.0 — fixed in 1.5.0
- Dell Inspiron 5585 Firmware: before 2.7.0 — fixed in 2.7.0
- Dell Inspiron 5675 Firmware: before 1.5.0 — fixed in 1.5.0
- Dell Inspiron 5775 Firmware: before 1.5.0 — fixed in 1.5.0
- Dell Inspiron 7375 Firmware: before 1.6.0 — fixed in 1.6.0
- Dell Inspiron 7405 Firmware: before 1.7.0 — fixed in 1.7.0
- Dell Inspiron 7415 Firmware: before 1.7.1 — fixed in 1.7.1
- Dell Vostro 3405 Firmware: before 1.5.0 — fixed in 1.5.0
- Dell Vostro 3515 Firmware: before 1.4.0 — fixed in 1.4.0
- Dell Vostro 5415 Firmware: before 1.7.1 — fixed in 1.7.1
- Dell Vostro 5515 Firmware: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: Dell G5 5505 Firmware 1.10.0; Dell Inspiron 22-3275 Firmware 1.8.0; Dell Inspiron 24-3475 Firmware 1.8.0; Dell Inspiron 27 7775 Firmware 2.15.0; Dell Inspiron 3180 Firmware 1.4.4; Dell Inspiron 3185 Firmware 1.4.4; Dell Inspiron 3195 Firmware 1.4.1; Dell Inspiron 3505 Firmware 1.5.0; Dell Inspiron 3515 Firmware 1.4.0; Dell Inspiron 3585 Firmware 1.6.0; Dell Inspiron 3595 Firmware 1.2.1; Dell Inspiron 3785 Firmware 1.6.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000199285/dsa-2022-095
- https://www.dell.com/support/kbdoc/en-us/000199285/dsa-2022-095
Get alerted when CVE-2022-24417 or the next vulnerability affects your stack