What’s Vulnerable › Vulnerabilities
CVE-2022-24424
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-21 · updated 2026-06-17
- Weakness: CWE-22
Description
Dell EMC AppSync versions from 3.9 to 4.3 contain a path traversal vulnerability in AppSync server. A remote unauthenticated attacker may potentially exploit this vulnerability to gain unauthorized read access to the files stored on the server filesystem, with the privileges of the running web application.
Affected products
- Dell AppSync: from 3.9.0.0 before 4.4.0.0 — fixed in 4.4.0.0
How to fix
Upgrade to a fixed version: Dell AppSync 4.4.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-24424 or the next vulnerability affects your stack