What’s Vulnerable › Vulnerabilities
CVE-2022-24429: Arbitrary Code Injection
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-10 · updated 2026-06-17
- Weakness: CWE-94
Description
The package convert-svg-core before 0.6.3 are vulnerable to Arbitrary Code Injection when using a specially crafted SVG file. An attacker can read arbitrary files from the file system and then show the file content as a converted PNG file.
Affected products
- convert-svg-core: before 0.6.3 — fixed in 0.6.3
How to fix
Upgrade to a fixed version: convert-svg-core 0.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/neocotic/convert-svg/commit/a43dffaab0f1e419d5be84e2e7356b86ffac3cf1
- https://github.com/neocotic/convert-svg/issues/84
- https://snyk.io/vuln/SNYK-JS-CONVERTSVGCORE-2859212
- https://github.com/neocotic/convert-svg/commit/a43dffaab0f1e419d5be84e2e7356b86ffac3cf1
- https://github.com/neocotic/convert-svg/issues/84
- https://snyk.io/vuln/SNYK-JS-CONVERTSVGCORE-2859212
Get alerted when CVE-2022-24429 or the next vulnerability affects your stack