What’s Vulnerable › Vulnerabilities
CVE-2022-24433: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-11 · updated 2026-06-17
- Weakness: CWE-88
Description
The package simple-git before 3.3.0 are vulnerable to Command Injection via argument injection. When calling the .fetch(remote, branch, handlerFn) function, both the remote and branch parameters are passed to the git fetch subcommand. By injecting some git options it was possible to get arbitrary command execution.
Affected products
- simple-git: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: simple-git 3.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/steveukx/git-js/pull/767
- https://github.com/steveukx/git-js/releases/tag/simple-git%403.3.0
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2421245
- https://snyk.io/vuln/SNYK-JS-SIMPLEGIT-2421199
- https://github.com/steveukx/git-js/pull/767
- https://github.com/steveukx/git-js/releases/tag/simple-git%403.3.0
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2421245
- https://snyk.io/vuln/SNYK-JS-SIMPLEGIT-2421199
Get alerted when CVE-2022-24433 or the next vulnerability affects your stack