What’s Vulnerable › Vulnerabilities
CVE-2022-24437: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-01 · updated 2026-06-17
- Weakness: CWE-88
Description
The package git-pull-or-clone before 2.0.2 are vulnerable to Command Injection due to the use of the --upload-pack feature of git which is also supported for git clone. The source includes the use of the secure child process API spawn(). However, the outpath parameter passed to it may be a command-line argument to the git clone command and result in arbitrary command injection.
Affected products
- git-pull-or-clone: before 2.0.2 — fixed in 2.0.2
How to fix
Upgrade to a fixed version: git-pull-or-clone 2.0.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/lirantal/327e9dd32686991b5a1fa6341aac2e7b
- https://github.com/feross/git-pull-or-clone/commit/f9ce092be13cc32e685dfa26e7705e9c6e3108a3
- https://snyk.io/vuln/SNYK-JS-GITPULLORCLONE-2434307
- https://gist.github.com/lirantal/327e9dd32686991b5a1fa6341aac2e7b
- https://github.com/feross/git-pull-or-clone/commit/f9ce092be13cc32e685dfa26e7705e9c6e3108a3
- https://snyk.io/vuln/SNYK-JS-GITPULLORCLONE-2434307
Get alerted when CVE-2022-24437 or the next vulnerability affects your stack