What’s Vulnerable › Vulnerabilities
CVE-2022-2444: Visualizer: Tables and Charts Manager for WordPress <= 3.7.9 - Authenticated (Contributor+) PHAR Deserialization
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-18 · updated 2026-06-17
- Weakness: CWE-502
Description
The Visualizer: Tables and Charts Manager for WordPress plugin for WordPress is vulnerable to deserialization of untrusted input via the 'remote_data' parameter in versions up to, and including 3.7.9. This makes it possible for authenticated attackers with contributor privileges and above to call files using a PHAR wrapper that will deserialize the data and call arbitrary PHP Objects that can be used to perform a variety of malicious actions granted a POP chain is also present. It also requires that the attacker is successful in uploading a file with the serialized payload.
Affected products
- themeisle Visualizer: Tables and Charts Manager for WordPress: before 3.7.10 — fixed in 3.7.10
How to fix
Upgrade to a fixed version: themeisle Visualizer: Tables and Charts Manager for WordPress 3.7.10. Check the vendor advisory for mitigations.
References
- https://github.com/Codeinwp/visualizer/blob/master/classes/Visualizer/Module/Chart.php#L1115
- https://github.com/Codeinwp/visualizer/blob/master/classes/Visualizer/Source/Csv.php
- https://github.com/Codeinwp/visualizer/compare/v3.7.9...v3.7.10
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2752058%40visualizer&new=2752058%40visualizer&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9606d92-8061-4dfc-a6e2-509b54613277?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2444
- https://github.com/Codeinwp/visualizer/blob/master/classes/Visualizer/Module/Chart.php#L1115
- https://github.com/Codeinwp/visualizer/blob/master/classes/Visualizer/Source/Csv.php
- https://github.com/Codeinwp/visualizer/compare/v3.7.9...v3.7.10
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2752058%40visualizer&new=2752058%40visualizer&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d9606d92-8061-4dfc-a6e2-509b54613277?source=cve
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2444
Get alerted when CVE-2022-2444 or the next vulnerability affects your stack