What’s Vulnerable › Vulnerabilities
CVE-2022-24440: Command Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-88
Description
The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Affected products
- cocoapods-downloader: before 1.6.0; 1.6.2 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: cocoapods-downloader 1.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/CocoaPods/cocoapods-downloader/pull/124
- https://github.com/CocoaPods/cocoapods-downloader/pull/128
- https://snyk.io/vuln/SNYK-RUBY-COCOAPODSDOWNLOADER-2414278
- https://github.com/CocoaPods/cocoapods-downloader/pull/124
- https://github.com/CocoaPods/cocoapods-downloader/pull/128
- https://snyk.io/vuln/SNYK-RUBY-COCOAPODSDOWNLOADER-2414278
Get alerted when CVE-2022-24440 or the next vulnerability affects your stack