What’s Vulnerable › Vulnerabilities
CVE-2022-24450
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-08 · updated 2026-06-17
- Weakness: CWE-862
Description
NATS nats-server before 2.7.2 has Incorrect Access Control. Any authenticated user can obtain the privileges of the System account by misusing the "dynamically provisioned sandbox accounts" feature.
Affected products
- nats-io nats-server: from 2.0.0 before 2.7.2 — fixed in 2.7.2
- Nats Streaming Server: from 0.15.0 before 0.24.1 — fixed in 0.24.1
How to fix
Upgrade to a fixed version: nats-io nats-server 2.7.2; Nats Streaming Server 0.24.1. Check the vendor advisory for mitigations.
References
- https://advisories.nats.io/CVE/CVE-2022-24450.txt
- https://github.com/nats-io/nats-server/releases/tag/v2.7.2
- https://advisories.nats.io/CVE/CVE-2022-24450.txt
- https://github.com/nats-io/nats-server/releases/tag/v2.7.2
Get alerted when CVE-2022-24450 or the next vulnerability affects your stack