What’s Vulnerable › Vulnerabilities
CVE-2022-2448: reSmush.it Image Optimizer < 0.4.6 - Admin+ Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The reSmush.it WordPress plugin before 0.4.6 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when unfiltered_html is disallowed.
Affected products
- reSmush.it : the only free Image Optimizer & compress plugin: before 0.4.6 — fixed in 0.4.6
How to fix
Upgrade to a fixed version: reSmush.it : the only free Image Optimizer & compress plugin 0.4.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a4599942-2878-4da4-b55d-077775323b61
- https://wpscan.com/vulnerability/a4599942-2878-4da4-b55d-077775323b61
Get alerted when CVE-2022-2448 or the next vulnerability affects your stack