What’s Vulnerable › Vulnerabilities
CVE-2022-24614
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-770
Description
When reading a specially crafted JPEG file, metadata-extractor up to 2.16.0 can be made to allocate large amounts of memory that finally leads to an out-of-memory error even for very small inputs. This could be used to mount a denial of service attack against services that use metadata-extractor library.
Affected products
- Metadata-Extractor Project Metadata-Extractor: before 2.18.0 — fixed in 2.18.0
How to fix
Upgrade to a fixed version: Metadata-Extractor Project Metadata-Extractor 2.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/drewnoakes/metadata-extractor/issues/561
- https://github.com/drewnoakes/metadata-extractor/issues/561
Get alerted when CVE-2022-24614 or the next vulnerability affects your stack