What’s Vulnerable › Vulnerabilities
CVE-2022-24615
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-755
Description
zip4j up to v2.10.0 can throw various uncaught exceptions while parsing a specially crafted ZIP file, which could result in an application crash. This could be used to mount a denial of service attack against services that use zip4j library.
Affected products
- zip4j: before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: zip4j 2.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/srikanth-lingala/zip4j/issues/377
- https://github.com/srikanth-lingala/zip4j/issues/418
- https://github.com/srikanth-lingala/zip4j/issues/377
- https://github.com/srikanth-lingala/zip4j/issues/418
Get alerted when CVE-2022-24615 or the next vulnerability affects your stack