What’s Vulnerable › Vulnerabilities

CVE-2022-24684

Description

HashiCorp Nomad and Nomad Enterprise 0.9.0 through 1.0.16, 1.1.11, and 1.2.5 allow operators with job-submit capabilities to use the spread stanza to panic server agents. Fixed in 1.0.18, 1.1.12, and 1.2.6.

Affected products

How to fix

Upgrade to a fixed version: HashiCorp Nomad Enterprise 1.0.18, 1.1.12, 1.2.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-24684 or the next vulnerability affects your stack