What’s Vulnerable › Vulnerabilities

CVE-2022-24687

Description

HashiCorp Consul and Consul Enterprise 1.9.0 through 1.9.14, 1.10.7, and 1.11.2 clusters with at least one Ingress Gateway allow a user with service:write to register a specifically-defined service that can cause Consul servers to panic. Fixed in 1.9.15, 1.10.8, and 1.11.3.

Affected products

How to fix

Upgrade to a fixed version: HashiCorp Consul 1.10.8, 1.11.3, 1.9.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-24687 or the next vulnerability affects your stack