What’s Vulnerable › Vulnerabilities
CVE-2022-2469
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-19 · updated 2026-06-17
- Weakness: CWE-125
Description
GNU SASL libgsasl server-side read-out-of-bounds with malicious authenticated GSS-API client
Affected products
- Debian Linux: 10.0, 11.0
- GNU SASL: before 2.0.1 — fixed in 2.0.1
How to fix
Upgrade to a fixed version: GNU SASL 2.0.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2469.json
- https://gitlab.com/gsasl/gsasl/-/commit/796e4197f696261c1f872d7576371232330bcc30
- https://www.debian.org/security/2022/dsa-5189
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2469.json
- https://gitlab.com/gsasl/gsasl/-/commit/796e4197f696261c1f872d7576371232330bcc30
- https://www.debian.org/security/2022/dsa-5189
Get alerted when CVE-2022-2469 or the next vulnerability affects your stack