What’s Vulnerable › Vulnerabilities
CVE-2022-24697: Apache Kylin prior to 4.0.2 allows command injection when the configuration overwrites function overwrites system parameters
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 84.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-13 · updated 2026-06-17
- Weakness: CWE-78
Description
Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.
Affected products
- Apache Software Foundation Apache Kylin: from 2.0.0 before 2.6.6; from 3.0.0 through 3.1.2; from 4.0.0 through 4.0.1 — fixed in 2.6.6
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kylin 2.6.6. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/12/30/1
- https://lists.apache.org/thread/07mnn9c7o314wrhrwjr10w9j5s82voj4
- http://www.openwall.com/lists/oss-security/2022/12/30/1
- https://lists.apache.org/thread/07mnn9c7o314wrhrwjr10w9j5s82voj4
Get alerted when CVE-2022-24697 or the next vulnerability affects your stack