What’s Vulnerable › Vulnerabilities
CVE-2022-2470: Cross-site Scripting (XSS) - Reflected in microweber/microweber
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 1.2.21.
Affected products
- microweber/microweber: before 1.2.21 — fixed in 1.2.21
How to fix
Upgrade to a fixed version: microweber/microweber 1.2.21. Check the vendor advisory for mitigations.
References
- https://github.com/microweber/microweber/commit/d28655183800b833abb20ccd55e1628f16ff65e4
- https://huntr.dev/bounties/3f1f679c-c243-431c-8ed0-e61543b9921b
- https://github.com/microweber/microweber/commit/d28655183800b833abb20ccd55e1628f16ff65e4
- https://huntr.dev/bounties/3f1f679c-c243-431c-8ed0-e61543b9921b
Get alerted when CVE-2022-2470 or the next vulnerability affects your stack