What’s Vulnerable › Vulnerabilities
CVE-2022-24709: Cross site scripting in @awsui/components-react
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-79
Description
@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.
Affected products
- Amazon Awsui/Components-React: before 3.0.367 — fixed in 3.0.367
How to fix
Upgrade to a fixed version: Amazon Awsui/Components-React 3.0.367. Check the vendor advisory for mitigations.
References
- https://github.com/aws/awsui-documentation/security/advisories/GHSA-mf22-92pm-m8p8
- https://www.npmjs.com/package/%40awsui/components-react
- https://github.com/aws/awsui-documentation/security/advisories/GHSA-mf22-92pm-m8p8
- https://www.npmjs.com/package/%40awsui/components-react
Get alerted when CVE-2022-24709 or the next vulnerability affects your stack