What’s Vulnerable › Vulnerabilities
CVE-2022-24711: Remote CLI Command Execution Vulnerability in CodeIgniter4
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-28 · updated 2026-06-17
- Weakness: CWE-20
Description
CodeIgniter4 is the 4.x branch of CodeIgniter, a PHP full-stack web framework. Prior to version 4.1.9, an improper input validation vulnerability allows attackers to execute CLI routes via HTTP request. Version 4.1.9 contains a patch. There are currently no known workarounds for this vulnerability.
Affected products
- CodeIgniter4: from 4.0.0 before 4.1.9 — fixed in 4.1.9
How to fix
Upgrade to a fixed version: CodeIgniter4 4.1.9. Check the vendor advisory for mitigations.
References
- https://github.com/codeigniter4/CodeIgniter4/commit/202f41ad522ba1d414b9d9c35aba1cb0c156b781
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-xjp4-6w75-qrj7
- https://github.com/codeigniter4/CodeIgniter4/commit/202f41ad522ba1d414b9d9c35aba1cb0c156b781
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-xjp4-6w75-qrj7
Get alerted when CVE-2022-24711 or the next vulnerability affects your stack