What’s Vulnerable › Vulnerabilities
CVE-2022-24720: Improper Input Validation in image_processing
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-01 · updated 2026-06-17
- Weakness: CWE-20
Description
image_processing is an image processing wrapper for libvips and ImageMagick/GraphicsMagick. Prior to version 1.12.2, using the `#apply` method from image_processing to apply a series of operations that are coming from unsanitized user input allows the attacker to execute shell commands. This method is called internally by Active Storage variants, so Active Storage is vulnerable as well. The vulnerability has been fixed in version 1.12.2 of image_processing. As a workaround, users who process based on user input should always sanitize the user input by allowing only a constrained set of operations.
Affected products
- Debian Linux: 11.0
- Image Processing Project Image Processing: before 1.12.2 — fixed in 1.12.2
How to fix
Upgrade to a fixed version: Image Processing Project Image Processing 1.12.2. Check the vendor advisory for mitigations.
References
- https://github.com/janko/image_processing/commit/038e4574e8f4f4b636a62394e09983c71980dada
- https://github.com/janko/image_processing/security/advisories/GHSA-cxf7-qrc5-9446
- https://www.debian.org/security/2022/dsa-5310
- https://github.com/janko/image_processing/commit/038e4574e8f4f4b636a62394e09983c71980dada
- https://github.com/janko/image_processing/security/advisories/GHSA-cxf7-qrc5-9446
- https://www.debian.org/security/2022/dsa-5310
Get alerted when CVE-2022-24720 or the next vulnerability affects your stack