What’s Vulnerable › Vulnerabilities
CVE-2022-24721: Incorrect Authorization in org.cometd.oort
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-15 · updated 2026-06-17
- Weakness: CWE-863
Description
CometD is a scalable comet implementation for web messaging. In any version prior to 5.0.11, 6.0.6, and 7.0.6, internal usage of Oort and Seti channels is improperly authorized, so any remote user could subscribe and publish to those channels. By subscribing to those channels, a remote user may be able to watch cluster-internal traffic that contains other users' (possibly sensitive) data. By publishing to those channels, a remote user may be able to create/modify/delete other user's data and modify the cluster structure. A fix is available in versions 5.0.11, 6.0.6, and 7.0.6. As a workaround, install a custom `SecurityPolicy` that forbids subscription and publishing to remote, non-Oort, sessions on Oort and Seti channels.
Affected products
- cometd: before 5.0.11; from 6.0.0 before 6.0.6; from 7.0.0 before 7.0.6 — fixed in 5.0.11, 6.0.6, 7.0.6
How to fix
Upgrade to a fixed version: cometd 5.0.11, 6.0.6, 7.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/cometd/cometd/issues/1146
- https://github.com/cometd/cometd/security/advisories/GHSA-rjmq-6v55-4rjv
- https://github.com/cometd/cometd/issues/1146
- https://github.com/cometd/cometd/security/advisories/GHSA-rjmq-6v55-4rjv
Get alerted when CVE-2022-24721 or the next vulnerability affects your stack