What’s Vulnerable › Vulnerabilities
CVE-2022-24722: Cross-site Scripting in view_component
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
VIewComponent is a framework for building view components in Ruby on Rails. Versions prior to 2.31.2 and 2.49.1 contain a cross-site scripting vulnerability that has the potential to impact anyone using translations with the view_component gem. Data received via user input and passed as an interpolation argument to the `translate` method is not properly sanitized before display. Versions 2.31.2 and 2.49.1 have been released and fully mitigate the vulnerability. As a workaround, avoid passing user input to the `translate` function, or sanitize the inputs before passing them.
Affected products
- github view_component: from 2.31.0 before 2.31.2; from 2.32.0 before 2.49.1 — fixed in 2.31.2, 2.49.1
How to fix
Upgrade to a fixed version: github view_component 2.31.2, 2.49.1. Check the vendor advisory for mitigations.
References
- https://github.com/github/view_component/commit/3f82a6e62578ff6f361aba24a1feb2caccf83ff9
- https://github.com/github/view_component/releases/tag/v2.31.2
- https://github.com/github/view_component/releases/tag/v2.49.1
- https://github.com/github/view_component/security/advisories/GHSA-cm9w-c4rj-r2cf
- https://github.com/github/view_component/commit/3f82a6e62578ff6f361aba24a1feb2caccf83ff9
- https://github.com/github/view_component/releases/tag/v2.31.2
- https://github.com/github/view_component/releases/tag/v2.49.1
- https://github.com/github/view_component/security/advisories/GHSA-cm9w-c4rj-r2cf
Get alerted when CVE-2022-24722 or the next vulnerability affects your stack