What’s Vulnerable › Vulnerabilities
CVE-2022-24723: Improper Input Validation in URI.js
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-03 · updated 2026-06-17
- Weakness: CWE-20
Description
URI.js is a Javascript URL mutation library. Before version 1.19.9, whitespace characters are not removed from the beginning of the protocol, so URLs are not parsed properly. This issue has been patched in version 1.19.9. Removing leading whitespace from values before passing them to URI.parse can be used as a workaround.
Affected products
- medialize/uri.js: before 1.19.9 — fixed in 1.19.9
How to fix
Upgrade to a fixed version: medialize/uri.js 1.19.9. Check the vendor advisory for mitigations.
References
- https://github.com/medialize/URI.js/releases/tag/v1.19.9
- https://github.com/medialize/URI.js/security/advisories/GHSA-gmv4-r438-p67f
- https://github.com/medialize/uri.js/commit/86d10523a6f6e8dc4300d99d671335ee362ad316
- https://huntr.dev/bounties/82ef23b8-7025-49c9-b5fc-1bb9885788e5/
- https://github.com/medialize/URI.js/releases/tag/v1.19.9
- https://github.com/medialize/URI.js/security/advisories/GHSA-gmv4-r438-p67f
- https://github.com/medialize/uri.js/commit/86d10523a6f6e8dc4300d99d671335ee362ad316
- https://huntr.dev/bounties/82ef23b8-7025-49c9-b5fc-1bb9885788e5/
Get alerted when CVE-2022-24723 or the next vulnerability affects your stack