What’s Vulnerable › Vulnerabilities
CVE-2022-24726: Unauthenticated control plane denial of service attack in Istio
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-10 · updated 2026-06-17
- Weakness: CWE-400
Description
Istio is an open platform to connect, manage, and secure microservices. In affected versions the Istio control plane, istiod, is vulnerable to a request processing error, allowing a malicious attacker that sends a specially crafted message which results in the control plane crashing when the validating webhook for a cluster is exposed publicly. This endpoint is served over TLS port 15017, but does not require any authentication from the attacker. For simple installations, Istiod is typically only reachable from within the cluster, limiting the blast radius. However, for some deployments, especially [external istiod](https://istio.io/latest/docs/setup/install/external-controlplane/) topologies, this port is exposed over the public internet. This issue has been patched in versions 1.13.2, 1.12.5 and 1.11.8. Users are advised to upgrade. Users unable to upgrade should disable access to a validating webhook that is exposed to the public internet or restrict the set of IP addresses that can query it to a set of known, trusted entities.
Affected products
- istio: before 1.11.8; from 1.12.0 before 1.12.5; from 1.13.0 before 1.13.2 — fixed in 1.11.8, 1.12.5, 1.13.2
How to fix
Upgrade to a fixed version: istio 1.11.8, 1.12.5, 1.13.2. Check the vendor advisory for mitigations.
References
- https://github.com/golang/go/issues/51112
- https://github.com/istio/istio/commit/6ca5055a4db6695ef5504eabdfde3799f2ea91fd
- https://github.com/istio/istio/security/advisories/GHSA-8w5h-qr4r-2h6g
- https://github.com/golang/go/issues/51112
- https://github.com/istio/istio/commit/6ca5055a4db6695ef5504eabdfde3799f2ea91fd
- https://github.com/istio/istio/security/advisories/GHSA-8w5h-qr4r-2h6g
Get alerted when CVE-2022-24726 or the next vulnerability affects your stack