What’s Vulnerable › Vulnerabilities

CVE-2022-24728: Cross-site Scripting in CKEditor4

Description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4 prior to version 4.18.0. The vulnerability allows someone to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. This problem has been patched in version 4.18.0. There are currently no known workarounds.

Affected products

How to fix

Upgrade to a fixed version: ckeditor4 4.18.0; Drupal 9.2.15, 9.3.8; Oracle Corporation Application Express 22.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-24728 or the next vulnerability affects your stack