What’s Vulnerable › Vulnerabilities

CVE-2022-24729: Regular expression Denial of Service in dialog plugin

Description

CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. CKEditor4 prior to version 4.18.0 contains a vulnerability in the `dialog` plugin. The vulnerability allows abuse of a dialog input validator regular expression, which can cause a significant performance drop resulting in a browser tab freeze. A patch is available in version 4.18.0. There are currently no known workarounds.

Affected products

How to fix

Upgrade to a fixed version: ckeditor4 4.18.0; Drupal 9.2.15, 9.3.8; Oracle Corporation Application Express 22.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-24729 or the next vulnerability affects your stack