What’s Vulnerable › Vulnerabilities
CVE-2022-24741: High memory usage in Nextcloud server
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-09 · updated 2026-06-17
- Weakness: CWE-400
Description
Nextcloud server is an open source, self hosted cloud style services platform. In affected versions an attacker can cause a denial of service by uploading specially crafted files which will cause the server to allocate too much memory / CPU. It is recommended that the Nextcloud Server is upgraded to 21.0.8 , 22.2.4 or 23.0.1. Users unable to upgrade should disable preview generation with the `'enable_previews'` config flag.
Affected products
- Nextcloud Server: from 21.0.0 before 21.0.8; from 22.0.0 before 22.2.4; 23.0.0 — fixed in 21.0.8, 22.2.4
How to fix
Upgrade to a fixed version: Nextcloud Server 21.0.8, 22.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-jf3h-xf4q-mh89
- https://github.com/nextcloud/server/pull/30291
- https://hackerone.com/reports/1261225
- https://security.gentoo.org/glsa/202208-17
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-jf3h-xf4q-mh89
- https://github.com/nextcloud/server/pull/30291
- https://hackerone.com/reports/1261225
- https://security.gentoo.org/glsa/202208-17
Get alerted when CVE-2022-24741 or the next vulnerability affects your stack