What’s Vulnerable › Vulnerabilities
CVE-2022-24743: Insufficient Session Expiration in Sylius
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-14 · updated 2026-06-17
- Weakness: CWE-613
Description
Sylius is an open source eCommerce platform. Prior to versions 1.10.11 and 1.11.2, the reset password token was not set to null after the password was changed. The same token could be used several times, which could result in leak of the existing token and unauthorized password change. The issue is fixed in versions 1.10.11 and 1.11.2. As a workaround, overwrite the `Sylius\Bundle\ApiBundle\CommandHandler\ResetPasswordHandler` class with code provided by the maintainers and register it in a container. More information about this workaround is available in the GitHub Security Advisory.
Affected products
- Sylius: from 1.10.0 before 1.10.11; from 1.11.0 before 1.11.2 — fixed in 1.10.11, 1.11.2
How to fix
Upgrade to a fixed version: Sylius 1.10.11, 1.11.2. Check the vendor advisory for mitigations.
References
- https://github.com/Sylius/Sylius/releases/tag/v1.10.11
- https://github.com/Sylius/Sylius/releases/tag/v1.11.2
- https://github.com/Sylius/Sylius/security/advisories/GHSA-mf3v-f2qq-pf9g
- https://github.com/Sylius/Sylius/releases/tag/v1.10.11
- https://github.com/Sylius/Sylius/releases/tag/v1.11.2
- https://github.com/Sylius/Sylius/security/advisories/GHSA-mf3v-f2qq-pf9g
Get alerted when CVE-2022-24743 or the next vulnerability affects your stack