What’s Vulnerable › Vulnerabilities
CVE-2022-24744: Insufficient Session Expiration in shopware
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-09 · updated 2026-06-17
- Weakness: CWE-613
Description
Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In affected versions user sessions are not logged out if the password is reset via password recovery. This issue has been resolved in version 6.4.8.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.
Affected products
- shopware: before 6.4.8.1 — fixed in 6.4.8.1
How to fix
Upgrade to a fixed version: shopware 6.4.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/platform/security/advisories/GHSA-w267-m9c4-8555
- https://github.com/shopware/platform/security/advisories/GHSA-w267-m9c4-8555
Get alerted when CVE-2022-24744 or the next vulnerability affects your stack