What’s Vulnerable › Vulnerabilities
CVE-2022-24746: HTML injection possibility in voucher code form
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In affected versions it is possible to inject code via the voucher code form. This issue has been patched in version 6.4.8.1. There are no known workarounds for this issue.
Affected products
- shopware: before 6.4.8.1 — fixed in 6.4.8.1
How to fix
Upgrade to a fixed version: shopware 6.4.8.1. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2022
- https://github.com/shopware/platform/commit/651598a61073cbe59368e311817bdc6e7fb349c6
- https://github.com/shopware/platform/security/advisories/GHSA-952p-fqcp-g8pc
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-02-2022
- https://github.com/shopware/platform/commit/651598a61073cbe59368e311817bdc6e7fb349c6
- https://github.com/shopware/platform/security/advisories/GHSA-952p-fqcp-g8pc
Get alerted when CVE-2022-24746 or the next vulnerability affects your stack