What’s Vulnerable › Vulnerabilities
CVE-2022-24748: Incorrect Authentication in shopware
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-09 · updated 2026-06-17
- Weakness: CWE-287
Description
Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In versions prior to 6.4.8.2 it is possible to modify customers and to create orders without App Permission. This issue is a result of improper api route checking. Users are advised to upgrade to version 6.4.8.2. There are no known workarounds.
Affected products
- shopware: before 6.4.8.2 — fixed in 6.4.8.2
How to fix
Upgrade to a fixed version: shopware 6.4.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/shopware/core/commit/329e4d7e028dd8081496cf8bd3acc822000b0ec0
- https://github.com/shopware/platform/security/advisories/GHSA-83vp-6jqg-6cmr
- https://github.com/shopware/core/commit/329e4d7e028dd8081496cf8bd3acc822000b0ec0
- https://github.com/shopware/platform/security/advisories/GHSA-83vp-6jqg-6cmr
Get alerted when CVE-2022-24748 or the next vulnerability affects your stack